Anachostic

My tagline, let me show you it.

A Troubleshooting Challenge

You have to love troubleshooting.

As a mentioned earlier, I’m doing a hard drive update on my Zune to bring it up to 120gb.  In the first chapter of this crazy process, I simply bought a 120gb 1.8” drive that was supposed to be IPod and Zune compatible.  I got the drive and prior to installing it, I erased the Zune completely, firmware and all.

After installation, the Zune wanted to be connected to the PC to install the new firmware.  After doing so, the Zune software registered a hard drive problem – not enough space on drive.  Hmmmmmmmm.  After thinking about it for a while, I considered that the base level of firmware back when the Zune 30gb came out might not support a 120gb drive, since they didn’t exist at that time.  So I thought I should bring the firmware up to the most recent, then install the new hard drive.

I put the old drive back in, upgraded the firmware, then put the new drive in and restarted.  Then I get a obscure (and yet common) error code.  So I think some more.  The new hard drive is a different brand – Samsung instead of Toshiba, and it uses more power – 4v instead of 3.3v.  Maybe it’s the drive that’s just incompatible?

So, I order a second drive, a Toshiba this time.  Without erasing the firmware, I install the drive.  The Zune boots to a “Please Wait” screen.  I wait for a few minutes and decide it’s not doing anything.  I power the Zune down, check the drive connections and start it up again.  Same screen.  I look online and the Internet says that that screen is shown during drive format and initialization (Do not disconnect or turn off the device).  Oops.  So I leave the Zune plugged in overnight.  The next morning, I left without remembering to check the status, so it ran all day while I worked.  When I get home, no progress.

I put the old drive back in and everything works just fine.  I put the new Toshiba in again and it doesn’t.  I put the old drive in, wipe out the firmware, put the new drive in and I get stuck at the “Please Wait” screen. Hmmm. The Samsung got past that screen but failed when writing the firmware.  The Toshiba doesn’t get past the drive initialization.  It’s actually a worse situation.

The next step of my troubleshooting is going to be at a lower level – the drives themselves.  One possible theory is that the drives can’t be formatted because they are not partitioned.  The company that sold me the drives may have run a diagnostic test that erased the drive’s file system.  So, I’ve ordered a ZIF to USB adapter so I can connect the drives to my computer and verify for myself.  Maybe I will need to create a partition and/or format the drives myself before installation.  As a side project, the adapter would let me see what kind of files are saved on the Zune itself.  That could be interesting information, too.

Running cost for this project: $70 for the two drives, $10 for the adapter.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: